Page 1 of 1

Boot issue after successful restore

Posted: Thu Sep 07, 2006 4:38 pm
by kwalker75
I have successfully made an image from a Gateway E2600S and restored to another, however, booting yields "disk read error". So I instinctively thought the partition wasn't marked active and bootable...that wasn't the case though, it was. So what I tried next was booting to XP cd (the image is of an NTFS XP machine) and did a FIXMBR and FIXBOOT. Still no go. What I'm going to try now is to try to simplify the setup by deleting the FAT32 partition (Gateways restore) and try again. I think, correct me if I'm wrong, what happened is that there is some discrepency between partition order in Linux and Windows.
What I'm trying to accomplish is to simply backup the NTFS partition of the template machine and deploy to 108 others...I figured the FAT32 partition shouldn't play a role. Has anyone had an experience with this kind of setup?
Sorry for the long post just trying to get as much pertinant information out here as possible. Any feedback would be greatly appreciated. Thanks in advance.

Posted: Fri Sep 15, 2006 9:44 am
by librelrs
That's normal: if you disk geometry changes, then Windows cannot boot anymore. There are very few tools which can fix the boot record after a restoration: Windows tools like Ghost, or the Linbox Rescue Server (fix just released).
or for the GPLed edition.



Posted: Sun Apr 01, 2007 2:11 pm
by Sebastian
Can you say what is wrong in the bootsektor when the dis geometry changes?

I tried to change a 20GB- Disk to a 40GB- Disk. So I made the backups of the two partitions and of mbr. Then I wrote the mbr to the new disk and restored the backups to it. But Windows didnt start. I dont know why. The only change is the hardware isnt it?
I tried some bootmanager where i could start directly the second partition on disk but it didnt work...


Posted: Tue Apr 10, 2007 8:22 am
by librelrs
The start of the Windows boot loader is hardcoded in the 1st boot sector.
But that start sector is specified using CHS, not LBA so it is disk specific. And the Windows boot sector needs to be updated.

If you need something that works, you can try your backup with the LRS demo vmware image :

Do not forget to enable the option "Restoration: update the NT boot loader if the HD has changed": ... tions_boot