partimage restore does not work with gzip -dc

Here are messages about how to use partimage from a bootable CDRom / floppy disk.

Moderator: feffer

Post Reply
Adam Welch
Posts: 1
Joined: Wed Dec 05, 2007 10:13 pm

partimage restore does not work with gzip -dc

Post by Adam Welch » Wed Dec 05, 2007 10:38 pm

I tried this...

cat *.000 *.001 | gzip -dc | partimage -b restore /dev/sda1 stdin

Restore never worked until I stopped using -V on the save and stopped using the pipeline invocation as above, sacrificing the file splitting feature so as to make it work. Again, I could never get images created with -V to work - some. This was with the latest stable as of yesterday, Dec 5. Some small addition background is that without gzip -dc it didn't work either, but with gzip -dc, I got further - up til the point where it appears that it stopped restoring from 000 and started using 001. I got some error message about local check not being found or something (sorry - in a bit of a rush, here).

Delphi
Posts: 3
Joined: Sun May 03, 2009 7:16 pm

Post by Delphi » Mon May 04, 2009 12:26 am

Sounds like my prob, but it seems me that not only the forum but even the authors of partimage are dead, or atleast don't look into the forum anymore :(

Post Reply