partimage on amd64??

Everything about the installation and compilation

Moderator: feffer

Post Reply
wolfchri

partimage on amd64??

Post by wolfchri » Fri Aug 06, 2004 4:09 pm

Hello,

did anybody manage to install partimage on amd64-systems?

In Suse 9.1-x64, it is broken, emerge on gentoo fails because of a bug in the xfs filesystem module

bash-2.05b# emerge partimage
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/partimage-0.6.4-r1 to /
>>> md5 src_uri ;-) partimage-0.6.4.tar.bz2
>>> Unpacking source..

if g++ -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -D_REENTRANT -D_FILE_OFFSET_BITS=64 -I. -I. -I../../.. -I../../.. -I../../../src/client -I../../../src/shared -I/usr/include/slang -Wno-deprecated -Wall -O3 -fomit-frame-pointer -funroll-loops -fprefetch-loop-arrays -pipe -mmmx -msse2 -m3dnow -mfpmath=sse,387 -MT fs_xfs.o -MD -MP -MF ".deps/fs_xfs.Tpo" -c -o fs_xfs.o fs_xfs.cpp; \
then mv -f ".deps/fs_xfs.Tpo" ".deps/fs_xfs.Po"; else rm -f ".deps/fs_xfs.Tpo"; exit 1; fi
In file included from fs_xfs.cpp:20:
fs_xfs.h:115: error: conflicting types for `typedef long long int __int64_t'
/usr/include/bits/types.h:47: error: previous declaration as `typedef long int
__int64_t'
fs_xfs.h:116: error: conflicting types for `typedef long long unsigned int
__uint64_t'
/usr/include/bits/types.h:48: error: previous declaration as `typedef long
unsigned int __uint64_t'
make[4]: *** [fs_xfs.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/partimage-0.6.4-r1/work/partimage-0.6.4/src/client/fs'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/partimage-0.6.4-r1/work/partimage-0.6.4/src/client'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/partimage-0.6.4-r1/work/partimage-0.6.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/partimage-0.6.4-r1/work/partimage-0.6.4'
make: *** [all] Error 2

!!! ERROR: sys-apps/partimage-0.6.4-r1 failed.
!!! Function src_compile, Line 69, Exitcode 2
!!! (no error message)

bash-2.05b#


On Gentoo, I tried 0.6.4 and 0.6.2, both did not compile.

This is sad because the amd64 is extremely fast compressing with bzip2 in 64 bit mode, as far as I can say.

The bug was reported by me to gentoo bugzilla as bug 55341

Any suggestions? I am using gcc 3.3.4 (that is the latest I can emerge)

CptKrf

Mine kind of works.

Post by CptKrf » Sun Aug 29, 2004 3:25 am

I have it sort of working on my AMD64 with Debian Woody. The version that comes with Knoppix 3.3 and the latest apt-get version for Debian all compile and run just fine, from a load and go standpoint.

However, I have a bug on all machines in which the only keys that work are the tab, space and enter which makes it almost impossible to use. I did find that the H key will act as a down arrow so the program can be used if you are careful in your keying. This bug has been reported before and for months.

CptKrf

wolfchri

Post by wolfchri » Wed Sep 01, 2004 1:54 pm

Mentioning Knoppix 3.3 and debian wood, I assume you are using partimage in 32-bit mode? It is workung fin in 32 bit mode for me, too. However, it would be way faster if working in 64-bit mode (cause of bzip2).

I tried it on the Debian 64bit AMD ediition, the package does not work either (on 64 bit). Same on suse 9.1, not working.


Please, dear developers, I am sure it can easily be fixed - can you give it a try? If I were not such a noob as I actually am, I would try to build my own ebuild without the jfs part (where the error occurs) an try that, however, I am simply too dumb to do that ;-)


DW

Post by DW » Thu Sep 02, 2004 2:16 am

I *think* I read somewhere about problems when compiling partimage with gcc 3.x.
If you have an older version of gcc (say 2.96) try that.

wolfchri

Post by wolfchri » Thu Sep 02, 2004 9:28 am

I will try that. However, I think that will lead to the result that I get a compiled binary that will not run, as I have it on debian-64 and Suse9.1-64.

maybe one of the devolopers will get an AMD64 soon and realize how fast this machine is. Then he will fix the bug soon, I am sure ;-) It is a real number cruncher - setiqhome packages in 2 hours..... that rocks. bzip2 is so fast that is working transparently - even a 30 MB file is extracted in a second.

DW

Post by DW » Thu Sep 02, 2004 9:23 pm

I have not seen a posting from either François Dupoux or Franck Ladurelle for quite some time.... :?


Guest

Post by Guest » Sat Aug 06, 2005 6:09 am

This is a bummer.

Post Reply