Has anyone sucessfully compiled 0.7.2 for amd64

Everything about the installation and compilation

Moderator: feffer

Post Reply
JackieBrown
Posts: 2
Joined: Mon Apr 10, 2006 4:59 am

Has anyone sucessfully compiled 0.7.2 for amd64

Post by JackieBrown » Mon Apr 10, 2006 5:17 am

I tried the various stable versions but none seem to work. This seems to be a common error. I get that it was compiled against an incompatible compiler.

I am using debian Sid

So I tried from source and the last stable version work even get past the beginning of ./configure

I am now trying the 0.7.2 and have gotten a lot further but I get stuck during make

Everything looked fine until:

compress.cpp: In member function 'virtual void CModulesCompress::Module()':
compress.cpp:96: error: cannot convert 'DWORD*' to 'uLongf*' for argument '2' to 'int compress(Bytef*, uLongf*, const Bytef*, uLong)'
make[5]: *** [compress.o] Error 1

kind went south after that. Any ideas?

fhj52
Posts: 1
Joined: Sat Jan 13, 2007 1:41 am

Post by fhj52 » Sat Jan 13, 2007 1:56 am

That might be a blessing in disguise.
The stable version compiles here(dual Opteron & openSUSE) but fails to run:
#> partimage
Error: sizeof(DWORD) != 4 (8)
This version has been compiled with an uncompatible version of gcc.

Read the ''This version has been compiled with an uncompatible version of gcc.'' again.

IF gcc was not compatible, it would not frigging compile!

Same thing with .6.4 and .6.5 ...

It runs with the SystemRescueCD version which is of course useless for making regular backup images of partitions.

The README states this is ALPHA code and is not to be trusted for anything valuable.
Is that still true ? ,,, after more than EIGHT YEARS!?!?

xingshou
Posts: 1
Joined: Mon Aug 20, 2007 2:44 pm

I have the same experience.

Post by xingshou » Mon Aug 20, 2007 3:16 pm

I have the same experience as JackieBrown and fhj52 said before.

I have built and installed partimage-0.6.6 but failed to run it because "This version has been compiled with an uncompatible version of gcc.'' error.

So I downloaded partimage-0.7.2-0.dag.src.rpm from http://dag.wieers.com and tried to build but failed due to the following error.

checking size of char... configure: error: cannot compute sizeof (char), 77
See `config.log' for more details.
error: Bad exit status from /var/tmp/rpm-tmp.30525 (%build)

I concluded that partimage does not support 64bit platform so far. And I am worndering if this excellent software is maintained now. I can see annoucement notice about version 0.6.5 and still provide only version 0.6.6 in the home page.

I hope to see a new version of partimage soon which supports 64bit platform.


Sungsoo Kim

Post Reply