configuring partimage 0.6.4 under SuSE Linux 9.0

Everything about the installation and compilation

Moderator: feffer

Post Reply
Guest

configuring partimage 0.6.4 under SuSE Linux 9.0

Post by Guest » Sat Apr 17, 2004 1:50 pm

In SuSE Linux 9.0, when I do ./configure --enable-all-static --enable-static I get this message:

Code: Select all

checking for fstatfs64... no
checking for open64... no
checking for char... yes
checking size of char... configure: error: cannot compute sizeof (char), 77
See `config.log' for more details.
When I look in config.log, it shows:

Code: Select all

configure:23150: gcc -o conftest -g -O2  -Wno-deprecated  conftest.c -lz -lnewt
-lbz2 -lpthread  /usr/lib/libslang.a /usr/lib/libnewt.a /usr/lib/libssl.a /usr/l
ib/libcrypto.a >&5
gcc: /usr/lib/libslang.a: No such file or directory
cc1: warning: "-Wno-deprecated" is valid for C++ but not for C/ObjC
configure:23153: $? = 1
configure: program exited with status 1
configure: failed program was:
So it seems like the error is totally misleading saying it cannot find sizeof(char) when it really should be telling me it can't find "slang-devel" which was all I had to install to get rid of the error message.

Vincent Breton
Posts: 3
Joined: Sat Apr 15, 2006 1:12 pm

Post by Vincent Breton » Sun Apr 16, 2006 5:21 pm

:shock:
The problem is the same with open Suse 10.
Install the slang package and the autoconf package too then rebuild the configure file with autoconf command.

With Yast2, find ssl package and install it. If necessary, try again autoconf.
I am not sure for this point about SSL because my partimaged server doesn't start but the client seems to work.

Vincent

Post Reply