Make fails on CentOS5

Everything about the installation and compilation

Moderator: feffer

Post Reply
deltatech
Posts: 1
Joined: Mon Jul 27, 2009 5:17 am

Make fails on CentOS5

Post by deltatech » Mon Jul 27, 2009 6:11 am

Unable to run make on CentOS5. Has anyone else seen this? Is there a solution?

Making all in shared
make[3]: Entering directory `/root/partimage-0.6.7/src/shared'
source='common.cpp' object='common.o' libtool=no \
DEPDIR=.deps depmode=none /bin/sh ../../depcomp \
g++ -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -D_REENTRANT -D_FILE_OFFSET_BITS=64 -I. -I../.. -I../.. -I../../src/client -I../../src/shared -I/usr/include/slang -Wno-deprecated -I/usr/include/openssl -Wall -c -o common.o common.cpp
../../depcomp: line 566: exec: g++: not found
make[3]: *** [common.o] Error 127
make[3]: Leaving directory `/root/partimage-0.6.7/src/shared'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/partimage-0.6.7/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/partimage-0.6.7'
make: *** [all] Error 2

feffer
Posts: 126
Joined: Tue Mar 17, 2009 4:30 am

Post by feffer » Mon Jul 27, 2009 6:55 pm

AFAIK, partimage is no longer being actively developed, so it is unlikely you'll get an answer from a dev. I'm running several debian based systems and am able to download partimage from distro repos, so no need to compile. Isn't partimage available as an rpm from one of your repos? If so, that would be the easy way. Or do you need an option that isn't in the pre-compiled version?

feffer

Post Reply