Booting NTFS Restored Partition

If you have a question about a file system (for example xfs, reiserfs, ...)

Moderator: feffer

Post Reply
volkdir
Posts: 1
Joined: Mon Mar 08, 2004 9:42 am

Booting NTFS Restored Partition

Post by volkdir » Mon Mar 08, 2004 9:55 am

Hi!

I've some Problems with a NTFS Partition backuped and restored with partimage. Althoug I used Win2k Recovery Tools fixboot and fixmbr I can't boot from the restored Bootpartition. If I use a bootfloppy the Win2K System boots up without problems.

What I have done:
1) Made a backup of hda1 with Partimage on my wifes PC. The hda1 device contains the Win2k Boot Drive. Burned the Backup to CD.
2) Made on my PC a hda1 partition with (nearly at least bigger) equal size.
3) Restored the Backup to this partition.
4) Boot the cloned system with a bootfloppy.
5) Installed some necessary drivers
<----- till here it works
6) tried several Win2k recovery options to get it booting from harddisk (fixboot/fixmbr/recoverydisk)

the NT Boot loader gives me no hint, what is wrong. The system just stops an says nothing?

Any further suggestions ?

DW

ntfsresize

Post by DW » Tue Mar 09, 2004 10:03 pm

*MAYBE* you could try running

Code: Select all

ntfsresize -f /dev/hda1
.
This also tries to fix the boot record.
see:http://mlf.linux.rulez.org/mlf/ezaz/ntf ... tml#static

I *THINK* you will find that http://www.sysresccd.org/ has the ntfs tools.

guest

cfdisk from a live linux cd

Post by guest » Fri Mar 19, 2004 3:40 am

cfdisk should tell you what it thinks is on the drive. It will say if it is marked bootable. what type of files system is on the drive. space used. I have had problems restoring heavily fragmented windows partitions and trying to get them to boot. the partimage works fine but when restoreing to a similar hardware machine they won't boot. :) but booted in knoppix i can always mount the restored drive and copy files from them if needed.

DW

Post by DW » Tue Mar 30, 2004 9:35 pm

This article may be of interest: http://www.nu2.nu/fixnt4/

nobody

boot a small remastered knoppix cd works for me

Post by nobody » Fri Apr 09, 2004 3:43 am

#!/bin/bash
# hard disk size
hd=`sfdisk -s /dev/hda`
# in MB
mbs=`expr $hd / 1024`
# remove all partitions
dd if=/dev/zero of=/dev/hda bs=512 count=1
# make a label for the disk
parted -s /dev/hda mklabel msdos
# repartition the drive
parted -s /dev/hda mkpart primary 0 $mbs
# set boot flag on
parted -s /dev/hda set 1 boot on
# container 4 Partimage
mkntfs -Q /dev/hda1
# get image file win2k
mount -t iso9660 /dev/sr0 /mnt/cdrom
# Partimage
partimage -b -f3 restore /dev/hda1 /mnt/cdrom/win2k.000
# maximize use of drive
ntfsresize -f /dev/hda1


reboot

this works for me. cfdisk shows a linux partiton but it boots win2k for me.

Jacob van der Meulen

partimage does not make the partition active on restore

Post by Jacob van der Meulen » Fri May 28, 2004 1:53 pm

Because I had the same problem that my restore on a new PC did not boot while the restore on the original PC did boot I found this forum and this question.

The problem was that when I created the new partition in qtparted (using sysresccd, great recovery CD) I forgot to make it active. I used to use Drive Image for my disk images but Drive Image makes the restored partition active. So initially I blamed partimage.

This forum brought me to the solution.

So to solve the problem, just make your partition active (or bootable).

Post Reply