-L option not implemented???

Messages about how to use partimage across a network (with the partimaged server, samba, nfs, ...)

Moderator: feffer

Regie_Soer

-L option not implemented???

Postby Regie_Soer » Mon Sep 27, 2004 2:48 pm

Hi!

I just messed around with partimage. I found that there is an option, telling the Server not to ask for username (-L or --nologin). When I start partimaged with this option, it says "nologin+ssl" in the status bar.

I now start a partimage client and enter the IP of the server. But when I'm trying to connect, I'm asked for a username and password. This cannot be left empty!! So where's the sense in the "nologin"-option of the server?

I tried to enable/disable certain option like SSL and entering a senseless username but it only works, when the Server is started without any argument (login+ssl in statusbar) and the client enters a valid username (i used the root-user).

Perhaps this should be fixed!

Thanks,
Regie

PS: I used 0.6.4!

jorge_angel_cg
Posts: 4
Joined: Tue Jul 18, 2006 1:02 pm

Postby jorge_angel_cg » Tue Aug 01, 2006 12:20 pm

Idem. Anyone knows how to use partimaged with nologin ???
partimaged -L and partimaged --nologin doesn't work

mp
Posts: 6
Joined: Wed Aug 23, 2006 12:27 am

V. 0.6.4-14 ubuntu Definitely Broken

Postby mp » Wed Aug 23, 2006 12:51 am

Doesn't work.

I did battle with the client+server until way too late last night and found the following:

1. client doesn't have a nologin option
2. something about the default permissions on the users allowed file is not right because the server doesn't start and the documentation is pitifully vague on what the permissions should be.
3. No matter the user or password, the server rejects them. Is this a system user or what? Documentation doesn't specify.
4. Theoretically, the applications log when setting d=1 or d1 or whatever. Practically, it does not.

I can recommend bacula, though it's more complicated to set up. If you are familiar with symantec's tape backup application, you'll hook right into bacula. Better than the sleep I lost trying to save a disk.

Kermit
Posts: 3
Joined: Mon Oct 02, 2006 9:12 pm

Postby Kermit » Mon Oct 02, 2006 9:25 pm

At debian (partimage 0.6.4):
I add a user to /etc/partimagedusers
Then I tried:
partimaged-passwd MYUSER
and got:

`--# partimaged-passwd
Could not find db_load/db_dump!
Please install the db4.4-util package.
Version 4.2 and 4.3 are sufficient too.


apt-get install db4.4-util

Then it worked, but from a client over network, login ist still rejected :(
From localhost (connect to server ip: localhost or 127.0.0.1) the login is accepted.

morgan_greywolf
Posts: 1
Joined: Mon Oct 16, 2006 12:10 am

Re: -L option not implemented???

Postby morgan_greywolf » Mon Oct 16, 2006 12:17 am

Regie_Soer wrote:Hi!

I just messed around with partimage. I found that there is an option, telling the Server not to ask for username (-L or --nologin). When I start partimaged with this option, it says "nologin+ssl" in the status bar.


If you're using the client on the System Rescue CD, then it's because the client you're using doesn't have SSL enabled, while the server does. I've noticed this particularly in the Debian packages.

There's no way of turning off SSL support in SSL-enabled binaries. You can either download the source to the client and build an SSL-enabled client (and setup the necessary certficates/keys), or you can download the source to the server and build a non-SSL enabled server (compile with --disable-ssl)


Return to “Usage across network”

Who is online

Users browsing this forum: No registered users and 1 guest