partimaged versions mismatch

Messages about how to use partimage across a network (with the partimaged server, samba, nfs, ...)

Moderator: feffer

Guest

partimaged versions mismatch

Postby Guest » Sun Mar 21, 2004 4:13 pm

Okay, go easy on me here guys, I'm coming from a Windows/Ghost environment so thie partimage stuff is new to me.

But I've followed their documentation the best I know how and I set up partimage and partimaged on another box (both built without SSL) and I specified the -L flag when starting partimaged and I keep getting "versions mismatch". Any ideas what I'm doing wrong???

Guest

version mismatch

Postby Guest » Fri Mar 26, 2004 5:22 pm

Well, basically this just means that the server version differs from the client version.
Check "partimage -v" :)


thalunil

davee
Posts: 1
Joined: Wed Mar 31, 2004 3:31 pm

Re: version mismatch

Postby davee » Wed Mar 31, 2004 3:32 pm

Anonymous wrote:Well, basically this just means that the server version differs from the client version.
Check "partimage -v" :)


I've seen this too. I understand the error message, but can I ask why it is necessary for exactly the same version of partimage to be on the client and the server?

badseed

Postby badseed » Tue May 25, 2004 9:37 am

Hi,

This is appening to me too.

I have a client (Debian testing) <<Partition Image version 0.6.4 (distributed under the GNU GPL2)>> and a server (Fedora Core 2) <<Partition Image Daemon version 0.6.4 (distributed under the GNU GPL 2)>>.

The error is the same, I checked the installation packages (Debian 0.6.4-5) and (FC2 0.6.4-1.1) and for disaster recovery I'm downloading (System rescue 0.2.13) with partimage 0.6.3 inside.

With this I cannot plan a disaster recovery strategy... :cry:

This version mismatch can be a litle complicated to handle.
Major version incompability a can understand, but minor version changes are a little hard to be seen as an version incompability.

Isn't it of your interest that every distribution as the same version of partimage ??

Thanks
BaDSeeD

Note: For comuditty must people I know prefer installing dist packages instead of tarbars.
Is there many major changes from 0.6.4-1-1 to 0.6.4-5 that would invalidate a client/server connection?

mykolz05

version miss-match

Postby mykolz05 » Wed Feb 23, 2005 5:10 pm

Im having the same problem. Im sure that the versions match. This problem puts me at a complete standstill until the problem is resolved.
any help in assisting in the situation would be greatly appreciated.

markauk
Posts: 2
Joined: Sun Apr 17, 2005 9:50 am

Postby markauk » Sun Apr 17, 2005 9:53 am

I was having similar problems and solved as follows:-

* download 0.64 binaries from this site
* use these binaries at both ends
* make sure that SSL and user options are the same at both ends

I think the 'version' mismatch has more to do with compilation options - hence make sure you use partimage and partimaged which have been compiled with the same options.

l337ing disorder
Posts: 2
Joined: Fri Feb 13, 2009 6:33 pm

Postby l337ing disorder » Fri Feb 13, 2009 9:37 pm

markauk wrote:I was having similar problems and solved as follows:-

* download 0.64 binaries from this site

.


Where are the binaries on this site? Can't find them in the downloads section...

michel
Posts: 2
Joined: Thu Jun 11, 2009 5:06 pm

incompatible version

Postby michel » Thu Jun 11, 2009 7:14 pm

If you use the systemrescuecd it is not always possible to use the same binaries on the client and the server.

The 'incompatible version' error is really picky about, well, not only version numbers, but also about compile options: they have to match to the letter!

Which is ridiculous and have made me, in the past, forget about this tool. Recently I updated my systemrescue CD to get support for newer systems and, foolishly, i tried again.

I compiled a new version myself on the server because i needed to use version 0.6.7 and the server had only a really old version. At first I compiled with the ssl option, since it was the default, only to find that the one on systemrescuecd was compiled without SSL....So i recompiled the server. But still got the same error: incompatible version. Looking at the header the server reported ' 0.6.7 LOG' while the client version only reported '0.6.7'

There is no option in configure to tell me what this LOG is or how to disable it. I tried using -L on the server to allow without logins, but it all does not seem to make a difference.

The devs should really get this 'incompatible' problem fixed cause i think this could be a great, if not awesome utility. Too bad as well cause I spend too much time on getting this to work...

And guys, seriously, really, is it that necessary to have a captcha and and anti-bot making me count the number of arrows. AND sending me an activation by email before I can use my new account. Don't tell me it is that much work to remove unwanted accounts. You guys need to let go of a few paranoia check here and there. Seriously.

michel
Posts: 2
Joined: Thu Jun 11, 2009 5:06 pm

Afterthought

Postby michel » Fri Jun 12, 2009 6:36 am

I know i sounded a bit harsh in my previous post. Sorry about that.

I'm just frustrated about the fact that this problem has been around for so long. Also because partimaged feels like a bit like a backup without a restore. You know anyone who used/uses the DOS or windows backup tools? Right, neither do I.

I would suggest putting the partimaged in the unstable/experimental/bleeding-edge section so peeps know it doesn't always work. And that that they should stick to using samba or nfs mounted shares if they want network functionality.

feffer
Posts: 126
Joined: Tue Mar 17, 2009 4:30 am

Postby feffer » Sat Jun 13, 2009 11:32 pm

As far as I know, partimage isn't being actively developed, so asking the devs to do this or that might be futile. I have used partimage-partimaged successfully and the versions differ slightly (0.6.7-1 server vs. 0.6.7-2 debian client), so it probably depends upon how they're compiled.

This fussiness is probably why some people consider the tool unreliable. fwiw, I have used it several times to restore images to the same partitions and to different ones on different machines. Always worked perfectly.

If you're getting beat up trying to get partimage working across a network, there is an easy work-around: save the image locally and when it finishes, copy it to the remote server. See this comment on doing this (you don't necessarily have to use ssh, of course).

You must, of course, boot the local machine either from a live CD like Knoppix, or if it's a dual-boot machine from another partition since the target partition must not be "live" (the active booted partition). From there, it should be easy to save an image. You could even attach an external hd, mount it and save the image there. Once you have a good image, copy it to your server using the usual tools. Hope this helps.

feffer


Return to “Usage across network”

Who is online

Users browsing this forum: No registered users and 1 guest