How to configure partimage-server NOT to use SSL?

Messages about how to use partimage across a network (with the partimaged server, samba, nfs, ...)

Moderator: feffer

valuequest
Posts: 2
Joined: Tue Mar 07, 2006 9:03 pm
Location: Chesapeake, VA

How to configure partimage-server NOT to use SSL?

Postby valuequest » Tue Mar 07, 2006 9:47 pm

I have attempted to install partimage-server 0.6.4 to my system from an .rpm package. I THINK that I have followed the documentation instructions properly:
> I added user partimag to the system.
> I added users partimag and root to the /usr/local/etc/partimaged/partimagedusers file.
> I edited permissions for /usr/local/etc/partimaged/partimagedusers so that owner=partimag and number view=600

When I try to run # partimaged as either root or partimag, though, I get the following error:

error when verifying /usr/local/etc/partimaged/partimaged.key, check logfile for help
logfile is /var/log/partimaged.log
if you don't have logfile, use partimaged --debug=1


This error, combined with a once-over of readme file, leads me to think that the program is looking for an SSL key. In this case, though, SSL encryption probably is not necessary. Might any experienced users have any suggestions on how to configure and/or start partimage-server to run in a mode that does not require SSL keys or certificates?

nosilver4u
Posts: 2
Joined: Thu Aug 28, 2008 2:25 pm

disable ssl

Postby nosilver4u » Thu Aug 28, 2008 2:27 pm

Unfortunately (someone correct me if I'm wrong), you can only disable ssl at compile time. Fortunately, that's really simple, just install the dev packages for the stuff listed on the installation page. Then, when you're ready, use ./configure --disable-ssl


Return to “Usage across network”

Who is online

Users browsing this forum: No registered users and 1 guest