Black screen after restoring partitions on bigger partitions

Go there if you encounter an unexpected error when using the softare. For installation problems, use another forum.

Moderator: feffer

pherminie
Posts: 2
Joined: Fri Dec 10, 2010 9:53 am

Black screen after restoring partitions on bigger partitions

Postby pherminie » Fri Dec 10, 2010 10:13 am

Hello,

I try to experiment a "Linux/Debian Disaster Recovery Procedure". I use Partimage to do this on a test machine.


The steps :
- Basic install of Debian with autopartitionning : /, /home, /var, /usr, /tmp on different partitions --> Successfulled
- Partimage to backup the partitions on external server : successfulled
- Delete all partitions with GPARTED : successfulled
- Create partitions with GPARTED with the same numbers and with bigger sizes for all partitions as, at least, requested to be able to restore : successfulled
- Partimage to restore all partitions previously backuped : successfulled.

Reboot the machine : failed. I have a black screen after machine bios started with no prompt.

Thansk for you help.

Patrice (France)

feffer
Posts: 126
Joined: Tue Mar 17, 2009 4:30 am

Postby feffer » Mon Dec 13, 2010 1:18 am

Sounds like a bootloader problem. I assume you're using GRUB? Try booting the machine with a liveCD, like SystemRescueCD or Ubuntu and reinstall GRUB. I think it is grub-install and then update-grub. You might have to designate the partition...something like /dev/sda

pherminie
Posts: 2
Joined: Fri Dec 10, 2010 9:53 am

Postby pherminie » Mon Dec 13, 2010 3:02 pm

Thanks feffer,

I've restored the MBR previously backuped and the entries of the extended partitions and it works fine now.

I've restored the partition data with Partimage and reboot.

I keep your advice cause it could be usefull when I have to install Grub.

Thanks again.

Patrice.


Return to “Unexpected errors during usage”

Who is online

Users browsing this forum: No registered users and 4 guests