Error setting up cron job

Go there if you encounter an unexpected error when using the softare. For installation problems, use another forum.

Moderator: feffer

Post Reply
Vermyndax
Posts: 3
Joined: Wed Jun 16, 2004 7:52 pm
Contact:

Error setting up cron job

Post by Vermyndax » Wed Jun 16, 2004 7:55 pm

I have a cron job trying to run partimage with -b (v0.6.4... 0.6.4-r1 built from Gentoo Portage, actually).

I get a "TERM environment variable not set" error.

I thought the -b command line switch allowed you to get around this?

I tried applying the fully-batch-mode.patch but it was for 0.6.2 and failed to patch the source.


Vermyndax
Posts: 3
Joined: Wed Jun 16, 2004 7:52 pm
Contact:

the thread you posted

Post by Vermyndax » Mon Jun 21, 2004 5:58 am

That thread you posted doesn't seem to really answer the question... except to say that maybe I'm just not going to get partimage to work from a cron job and it's planned for future development?

DW

Post by DW » Mon Jun 21, 2004 9:35 pm

Yes, you are correct: I do not have a definitive answer for you. I only have pointers that *may* help you. More research is needed to really answer your question.
Have you read:http://www.partimage.org/oldforums/viewtopic.php?t=95?

Vermyndax
Posts: 3
Joined: Wed Jun 16, 2004 7:52 pm
Contact:

no go...

Post by Vermyndax » Mon Jun 21, 2004 11:24 pm

Well, tried redirecting the output to a file... and the output said the same thing - TERM variable must be set. :(

DW

Post by DW » Wed Jun 23, 2004 12:56 am

I've had a bit of a look at the source code (but I am flat out spelling C, let alone programming in it.).
It looks like the "Fully batch mode" patch is already in 0.6.4 It would also appear that the way to use it is via the -B option (not to be mistaken for the -b option).
The -B option wants a "challenge response string", but I don't understand just what that is.

DW

-B option

Post by DW » Wed Jun 23, 2004 9:39 pm

I don't think that the value for the -B option does anything, but it does need to be there.
In other words you need to use -B=something , but partimage does not seem to care what "something" is. So try:

partimage -B=foo save -z1 -f3 -b -d /dev/hda1 /mnt/backup/`date +%d%b%G`.pi064.gz

tarapozan
Posts: 1
Joined: Fri Jun 03, 2011 8:03 am

Post by tarapozan » Fri Jun 03, 2011 8:06 am

crons do not need any background veritable to be set, cron is background )
astigmatism

Vladyghost
Posts: 1
Joined: Thu Jan 05, 2012 8:31 pm
Contact:

help

Post by Vladyghost » Fri Jan 06, 2012 2:43 pm

Im having the same problem and this is lookinf chinese to me right now please help

Post Reply