Page 1 of 1

Cannot restore smaller source partition to a larger destinat

Posted: Fri Jun 05, 2009 5:28 am
by molly
I can not seem to restore a smaller ext3 partition (13GB) to a larger ext3 partition (17GB).

The source partition is from a 40 GB hard disk while the destination partition is from a 20GB h/disk.

Any help would be much appreciated ...


Posted: Sat Jul 25, 2009 7:29 pm
by feffer
Sorry for not seeing your post earlier. If your source partition is 13GB and your destination is 17GB, the restore should work. I assume you've done something like "df -h" or "fdisk -l" or similar to be sure. If so, try using "dd" instead of partimage. Lots of info on the web about dd.

While I continue to use partimage and have not had problems with saving or restoring images, it is not actively being developed (to my knowledge). One look at the forum is telling. This is unfortunate, because partimage performs a very useful service. There is a program called clonezilla that is based on partimage, but I would recommend dd (a command line app) for those who have problems with partimage.


Posted: Fri Aug 19, 2011 4:34 pm
by Amoranemix
I seem to have the same problem. I want to clone a disk and someone who wanted to play a prank on me said that is easy to do with Linux. I have posted with problems on an Ubuntu forum. I was about to post there again, but the problems changed so that it now really seems related to Partimage rather than Ubuntu.

The original disk was 300 GB with 36GB used and the OS Windows XP. Partimage made 10 2GB compressed images. VUB-PC.gz.000 is the first.

Partimage was unable/unwilling to restore the partitions to a 60GB disk due to an unknown file system error. So I figured I'd format the disk first. Fdisk is a terminal program so I looked for an alternative. I found GNU Part, but it was terminal too, so I settled with Fdisk anyway. It managed to replace the 4 primary partitions of the drive by 1 primary partition, but was unable/unwilling to format the drive. So I asked Windows Vista to format the drive with the NTFS file system and it did. After wrestling a bit with the poor interface of Partimage and wondering why it says the file system is ext3fs, it turns out it has a bug that prevents it from restoring image parts > 2GB. Although mine aren't, I get the corresponding error. A workaround is to uncompress the image files. For that they need to be renamed. Apparently I don't have the permission to do that and am told I am not the owner of the files. I tried the command chown on two files and now I have 11 files i.s.o. 10 (a 1.5 kB file called VUB-PC.gz.000.000 has been added) and I still can't change their names. Trying Partimage again it complains the partition is too small. (The file size doesn't seem to be a problem anymore.) Partimage says the original partition must be the same size as the destination partition.

How can I restore the image files to the disk ?

Posted: Fri Aug 19, 2011 8:41 pm
by feffer
The original disk was 300 GB with 36GB used...
Partimage was unable/unwilling to restore the partitions to a 60GB disk...
Partimage complains the partition is too small...
Partimage says the original partition must be the same size as the destination partition.
The manual explains that the partition you restore to must be (exactly) the same size as the source partition or larger. So if your original partition was 300 GB, the destination will have to be at least that big. It does not matter that the OS was only using 36GB, or that the compressed image is 10GB. You cannot restore a 300GB partition to a 60GB one. There are other tools that copy at the file level in both Windows and Linux. You might want to try one of those.

Posted: Sat Aug 20, 2011 7:19 am
by Amoranemix
That is what it says, but I find it unclear. In addition, the error message seemed to point to another problem. I tried again to check the error message, but this time I get another error. I'll probably end my Linux adventure here and rely on Acronis True Image.