Page 1 of 1

Disk Full error

Posted: Sun Nov 01, 2009 11:40 pm
by wseverin
Hi,

I'm attempting to backup the partition I have dedicated to Ubuntu Jaunty in anticipation of upgrading to Karmic. I have a 100+ GB ext3 partition on internal hard disk for Ubuntu, and I'm attempting to create a file image of it on external storage. The external drive is a 1.5TB hard disk on a USB interface; it's partitioned into four primary partitions, one of which is an ext3 partition of about 700GB just for maintaining backups. This disk seems to work perfectly in all other circumstances.

So here's the problem, running partimage 0.6.8 off of the systemrescueCD 1.3.1:

I get partimage running and making the backup image. I'm using bz compression. When the operation gets to where the output file is just over 1GB, the program pops up a dialog saying that the disk is full and that I need to put in a different file path to continue. Obviously the disk is nowhere near full. I've tried segmenting the output file at different sizes, as well as one contiguous file, but no joy. This is 100% repeatable.

I can't tell if this is a problem with partimage or with the drivers in the linux distribution on the system rescue CD. I don't think it's a problem with the local computer, its BIOS, or the external hard disk or its formatting.

Any ideas?

—W—

Disk Full error - solved

Posted: Mon Nov 02, 2009 3:03 am
by wseverin
I got it to work. I found that I had to manually mount the destination disk at /mnt/custom . Then using that path, "/mnt/custom/bla/bla.bla.gz" in the destination for partimage.

My hypothesis of the error goes like this:
1) On boot from the CD, the USB devices are not automatically mounted.
2) An unrecognized destination path in partimage is not necessarily detected,
3) ... resulting in a memory buffer being filled with output data until
4) ... there's no more room in RAM left. At which point the 'disk full error'

As I said, the cure was to manually mount the destination partition ("/dev/sdc4" in my case) at the "/mnt/custom" point in the path. That after much fiddling around with fstab and other possible solutions.

A bit of conspicuous documentation on this wouldn't hurt. Or maybe I missed it. Also, the folks who make the systemrescueCD might want to create more than one custom mount point; maybe "custom1" and "custom2" etc. It's entirely possible that one is using these utilities on more than one external disk in one session.

—W—

Posted: Thu Nov 05, 2009 6:34 pm
by feffer
I think your hypothesis of the error is correct. While I haven't checked the partimage docs lately, I believe they specify that the "source" partition must be unmounted and the "target" one mounted -- so maybe it was missed. Your explanation should help others who might have this issue.

You might want to think about the size of your Ubuntu partition. The system can easily fit in 10-15 GB, if you have your personal data on another partition. It is much faster to create/restore your image if personal data is not included. Upgrades are simpler. Of course, you already have your image, but in the future a different partitioning plan might be useful.

Regards,
feffer

Posted: Sat Oct 16, 2010 1:47 am
by Richard
I had the same problem this week. Finally had time to research and found this exchange.

Seems that the Documentation still needs to be updated? I downloaded last night from the Download page v0.6.9 and it still says unmount the USB.

Just applied the fix and awaiting to see it it gets past the Disk Full error.

Yes!! It does.
Thank you for posting this fix.

I had tried with partimage on a Peppermint usb and it worked 1 time; somehow, I entered a valid directory and it completed. The second time I was stumped. It is writing away to my external USB drive.

This time using a SysRescueCD written to a USB (for use on an Acer One), though not sure which version it has: 0.6.8 or 0.6.9.

Thanks, again, wseverin!