Windows not booting after restoring from image

Go there if you encounter an unexpected error when using the softare. For installation problems, use another forum.

Moderator: feffer

Post Reply
Daniel-H
Posts: 2
Joined: Wed Jan 06, 2010 7:09 pm

Windows not booting after restoring from image

Post by Daniel-H » Wed Jan 06, 2010 7:19 pm

Hi,

i'm new to partimage (used acronis/PQDI/Ghost before) but i have to use it because the previous admin made images with it, which i have to apply now.

I'm restoring images of Dell Vostro 220 PCs with SATA-HDD and Lenovo Notebooks with SATA-SSD. The image was made from identical machines.

My problem occurs on both systems, so i assume i do someting wrong...

This is what i do:
- delete all partitions
- restore MBR from image
- restore partition from image

Restoring is completed without any errors, but win XP doesn't start. I just get a black screen with flashing cursor. I know that this is an indication for a bootloader problem, so i did run recovery console and made fixmbr/fixboot/bootcfg without success.

In recovery console i have access to the file system and login works too, so the partition itself seems to be OK.

I'm using version 0.6.8 of lastest sysreccd. I assume the images were made with an older version.

Any ideas?

feffer
Posts: 126
Joined: Tue Mar 17, 2009 4:30 am

Post by feffer » Thu Jan 07, 2010 6:49 am

I'm familiar using partimage on linux partitions, but not winXP, so if anyone has experience with XP, please chime in. I'm assuming you already did a search of this forum and didn't get anything useful?

Partimage is useful for restoring partitions but more problematic for entire (multiple partition) discs. Some windows machines have hidden partitions for recovery/troubleshooting. If so, the partition table may have been messed up when you deleted all the partitions. I know how to fix this in linux, but not windows, but I'm guessing the ntbootloader might be getting confused by a different partition table. Could you reformat and create partitions exactly the same size as the original discs? Then restore the XP image to the proper partition w/sysreccd. Finally restore MBR from image?

If the original image was correctly made, the version of sysreccd shouldn't matter.

Daniel-H
Posts: 2
Joined: Wed Jan 06, 2010 7:09 pm

Post by Daniel-H » Thu Jan 07, 2010 7:13 am

I had the same idea tonight and tried it already this morning....and it worked on the Lenovo! Today i'll try the same with the Dell...

This is what i've done:
- Recovered original system state using Lenovo recovery CD. This has created a system partition and a recovery partition.
- started Ubuntu 9.10 and installed partimage 0.6.4 which i've found on the old admins PC, so i think he used this version to create the images
- restored only the partiton, not the MBR
- Reboot...all done

I don't think that ubuntu or version 0.6.4 fixed it (i'll try it on another one with sysreccd), i think you're right and the missing recovery partition was the problem. The original sizes where 114GB+4GB but i previously used a single 118GB to restore....bad mistake.

Thank you so much for your feedback!

Post Reply