problems during "make install"

Everything about the installation and compilation

Moderator: feffer

Post Reply

problems during "make install"

Post by ttilt » Sun Aug 08, 2004 12:13 am

I configure and make successfully, but then when I run make install I get the following error: (this are the last few lines)

Making install in po
make[1]: Entering directory `/home/ttilt/download/partimage-0.6.4/po'
/bin/sh `case "./mkinstalldirs" in /*) echo "./mkinstalldirs" ;; *) echo ".././mkinstalldirs" ;; esac` /usr/local/share
.././mkinstalldirs: .././mkinstalldirs: No such file or directory
make[1]: ** [install-data-yes] Erro 127
make[1]: Leaving directory `/home/ttilt/download/partimage-0.6.4/po'
make: ** [install-recursive] Erro 1

Obviously I run make install as root. I installed all required libraries above the minimum required version.

Does anyone know what could be causing this?

Thanks a lot


Post by Sputnik » Fri Aug 20, 2004 12:25 pm

Have a lookin the thread "had to edit po/Makefile for install" below this one, has work around that worked for me.

Laker Netman

Another fix for mkinstalldirs error during "make instal

Post by Laker Netman » Thu Jan 12, 2006 6:31 pm

I ran into this error on a fresh (fully updated) Fedora Core 4 install using version 0.6.4
My workaround:
cd into partimage src dir
ln -s /usr/share/automake-1.9/mkinstalldirs

This seemed to take care of the issue for me.


Post Reply