cannot create temp file (why?)

Go there if you encounter an unexpected error when using the softare. For installation problems, use another forum.

Moderator: feffer

Posts: 2
Joined: Fri Sep 23, 2005 6:25 pm

cannot create temp file (why?)

Postby Rhandir » Fri Sep 23, 2005 6:44 pm

While using Knoppix 3.9, I am trying to image hda1 (not mounted)
to uba1 (a hard disc connected by usb) by starting partimage with sudo.

I get the following error (or variations):

Cannot create temp file.
Please check that there is enough space and you have access rights.

I have tried these variations:
writing to /dev/null/image.img (same error)
writing to /dev/uba1/image.img (same error)
writing to /mnt/hda1/image.img (same error, I think)
unmounting uba1 and then trying to write to /mnt/uba1/image.img (same error)
Starting partimage without sudo, then trying to write to /mnt/uba1/image.img (access level warning and the same error)

The drive I am backing up is 4.5 Gig, with 4.1Gig free, using FAT32,
the drive I am writing to is 37 Gigs, with 20 Gig free, using FAT32

I've seen three other instances of the same problem in these forums:
However, no actual answers were provided.

as well as one ambiguously similar one:

This one
claims a hard limit of 4 gigs for devices. That seems unlikely.

Thank you!

Posts: 2
Joined: Fri Sep 23, 2005 6:25 pm

Solution to: "cannot create tempfile"

Postby Rhandir » Sun Sep 25, 2005 1:27 am

Short answer:
the drive you are writing the file to has to be mounted
the drive must not be write-only
you must spell the path correctly
partimage probably doesn't have the right user priveleges to run right

One or more of the following fixed my problem. I did all of them, so you tell me which was the key one.

1. Fix user priveleges, Fix ReadOnly,

Selected the drive I was copying to from the desktop.
Right click: get device properties.
Picked permissions tab, changed Group and Others to "can read and write", select the "executable" checkbox. (These steps are probably redundant, since I logged in as root later. Not sure how root treats the "readonly" media property, though.)
Picked Device tab.
Unchecked "read only" checkbox.
Noted the mount point was "/mnt/uba1" in the device tab.

2. Fix Mounting the drive.

Opened a terminal.
# sudo su
(logged in as root)
#umount /dev/hda1
(just to be sure. redundant? Note that it's umount not unmount)
#mount /dev/uba1
(use dev, since you are mounting a device. Don't use /mnt, that's the mount point)

3.Error message:

"dev/cloop0 inode error" Do you want to create it.
(huh? yes?)

4. Spelled the path correctly.

In partimage I highlighted hda1.
I wrote: /mnt/uba1/image.img
Note that mnt/uba1/image.img isn't the same thing, nor is dev/uba1/image.img

4. In the subsequent page, there's an option to set the split size in MiB. In someone claims a hard limit of 4 Gigs when writing to FAT32 drives. The default split size seems to be 2 Gigs (the old FAT32 limit), so you get a series of image files. Seems like a great solution.

5. etc. etc. Created a partition image. w00t!

1. I haven't restored the image yet, so I don't know if it is okay
2. This is because I can't seem to pass the keyboard commands to the menu to pick different options. (Restore vs. backup.) I'm used to dos, throw me a bone here! :) )
3. I don't understand what the cloop error is
4. I know that some of the steps are redundant, but I don't know which ones are.

Can anyone who can give me some insight into what happened that made this work?


Postby Guest » Tue Dec 20, 2005 5:28 am

use the spacebar to make selections - i learned that just today!

i'm having the same error, so hopefully your method will solve it for me, too.

Return to “Unexpected errors during usage”

Who is online

Users browsing this forum: No registered users and 1 guest